Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC gdbus library" |
| 2 | DESCRIPTION = "libopenbmc_intf provides a set of gpio access \ |
| 3 | methods and the GDBUS skeleton code for the org.openbmc DBUS API." |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit skeleton |
Saqib Khan | 02917df | 2017-11-13 10:47:54 -0600 | [diff] [blame] | 7 | inherit pkgconfig |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 8 | |
| 9 | DEPENDS += "glib-2.0" |
Matt Spinler | 71c1c92 | 2018-08-07 16:35:19 -0500 | [diff] [blame^] | 10 | DEPENDS += "cjson" |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 11 | |
| 12 | SKELETON_DIR = "libopenbmc_intf" |
| 13 | |
Matt Spinler | 71c1c92 | 2018-08-07 16:35:19 -0500 | [diff] [blame^] | 14 | SRC_URI += "file://gpio_defs.json" |
| 15 | |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 16 | do_install() { |
| 17 | oe_runmake install DESTDIR=${D} |
Matt Spinler | 71c1c92 | 2018-08-07 16:35:19 -0500 | [diff] [blame^] | 18 | |
| 19 | install -d ${D}${sysconfdir}/default/obmc/gpio/ |
| 20 | install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/ |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 21 | } |