Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Transport-Independent RPC library" |
| 2 | DESCRIPTION = "Libtirpc is a port of Suns Transport-Independent RPC library to Linux" |
| 3 | SECTION = "libs/network" |
| 4 | HOMEPAGE = "http://sourceforge.net/projects/libtirpc/" |
| 5 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=183075&atid=903784" |
| 6 | LICENSE = "BSD" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=f835cce8852481e4b2bbbdd23b5e47f3 \ |
| 8 | file://src/netname.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24" |
| 9 | |
| 10 | DEPENDS += "xz-native" |
| 11 | PROVIDES = "virtual/librpc" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2;name=libtirpc \ |
| 14 | ${GENTOO_MIRROR}/${BPN}-glibc-nfs.tar.xz;name=glibc-nfs \ |
| 15 | file://libtirpc-0.2.1-fortify.patch \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI_append_libc-uclibc = " file://remove-des-uclibc.patch" |
| 19 | |
| 20 | SRC_URI[libtirpc.md5sum] = "8cd41a5ef5a9b50d0fb6abb98af15368" |
| 21 | SRC_URI[libtirpc.sha256sum] = "62f9de7c2c8686c568757730e1fef66502a0e00d6cacf33546d0267984e002db" |
| 22 | SRC_URI[glibc-nfs.md5sum] = "5ae500b9d0b6b72cb875bc04944b9445" |
| 23 | SRC_URI[glibc-nfs.sha256sum] = "2677cfedf626f3f5a8f6e507aed5bb8f79a7453b589d684dbbc086e755170d83" |
| 24 | |
| 25 | inherit autotools pkgconfig |
| 26 | |
| 27 | EXTRA_OECONF = "--disable-gssapi" |
| 28 | |
| 29 | do_configure_prepend () { |
| 30 | cp -r ${S}/../tirpc ${S} |
| 31 | } |
| 32 | |
| 33 | do_install_append() { |
| 34 | chown root:root ${D}${sysconfdir}/netconfig |
| 35 | } |