Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "SysV init scripts which are only used in an LSB image" |
| 2 | SECTION = "base" |
| 3 | LICENSE = "GPLv2" |
| 4 | DEPENDS = "popt glib-2.0" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=ebf4e8b49780ab187d51bd26aaa022c6" |
| 7 | |
| 8 | S="${WORKDIR}/initscripts-${PV}" |
| 9 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/initscripts/initscripts-${PV}.tar.bz2/9cce2ae1009750e84be37c09a028757e/initscripts-${PV}.tar.bz2 \ |
| 10 | file://functions.patch \ |
| 11 | file://0001-functions-avoid-exit-1-which-causes-init-scripts-to-.patch \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "9cce2ae1009750e84be37c09a028757e" |
| 15 | SRC_URI[sha256sum] = "48b59ce8157cfc58bbd4b1dfa58ad1087245761ae11c2033b66ae3864ea7e1cf" |
| 16 | |
| 17 | inherit update-alternatives |
| 18 | |
| 19 | ALTERNATIVE_PRIORITY = "100" |
| 20 | ALTERNATIVE_${PN} = "functions" |
| 21 | ALTERNATIVE_LINK_NAME[functions] = "${sysconfdir}/init.d/functions" |
| 22 | |
| 23 | # Since we are only taking the patched version of functions, no need to |
| 24 | # configure or compile anything so do not execute these |
| 25 | do_configure[noexec] = "1" |
| 26 | do_compile[noexec] = "1" |
| 27 | |
| 28 | do_install(){ |
| 29 | install -d ${D}${sysconfdir}/init.d/ |
| 30 | install -m 0644 ${S}/rc.d/init.d/functions ${D}${sysconfdir}/init.d/functions |
| 31 | sed -i 's,${base_bindir}/mountpoint,${bindir}/mountpoint,g' ${D}${sysconfdir}/init.d/functions |
| 32 | } |