Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Universal Addresses to RPC Program Number Mapper" |
| 2 | DESCRIPTION = "The rpcbind utility is a server that converts RPC \ |
| 3 | program numbers into universal addresses." |
| 4 | SECTION = "console/network" |
| 5 | HOMEPAGE = "http://sourceforge.net/projects/rpcbind/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751" |
| 7 | DEPENDS = "libtirpc quota" |
| 8 | |
| 9 | LICENSE = "BSD" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \ |
| 11 | file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \ |
| 14 | file://init.d \ |
| 15 | file://0001-Avoid-use-of-glibc-sys-cdefs.h-header.patch \ |
| 16 | file://remove-sys-queue.patch \ |
| 17 | ${UCLIBCPATCHES} \ |
| 18 | ${MUSLPATCHES} \ |
| 19 | file://rpcbind.conf \ |
| 20 | file://rpcbind.socket \ |
| 21 | file://rpcbind.service \ |
| 22 | " |
| 23 | MUSLPATCHES_libc-musl = "file://musl-sunrpc.patch" |
| 24 | |
| 25 | UCLIBCPATCHES_libc-uclibc = "file://0001-uclibc-nss.patch \ |
| 26 | " |
| 27 | UCLIBCPATCHES ?= "" |
| 28 | MUSLPATCHES ?= "" |
| 29 | |
| 30 | SRC_URI[md5sum] = "c8875246b2688a1adfbd6ad43480278d" |
| 31 | SRC_URI[sha256sum] = "9897823a9d820ea011d9ea02054d5ab99469b9ca5346265fee380713c8fed27b" |
| 32 | |
| 33 | inherit autotools update-rc.d systemd pkgconfig |
| 34 | |
| 35 | PACKAGECONFIG ??= "tcp-wrappers" |
| 36 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 37 | |
| 38 | INITSCRIPT_NAME = "rpcbind" |
| 39 | INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ." |
| 40 | |
| 41 | SYSTEMD_SERVICE_${PN} = "rpcbind.service" |
| 42 | |
| 43 | inherit useradd |
| 44 | |
| 45 | USERADD_PACKAGES = "${PN}" |
| 46 | USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \ |
| 47 | --shell /bin/false --user-group rpc" |
| 48 | |
| 49 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
| 50 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \ |
| 51 | --without-systemdsystemunitdir, \ |
| 52 | systemd \ |
| 53 | " |
| 54 | |
| 55 | EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc" |
| 56 | |
| 57 | do_install_append () { |
| 58 | mv ${D}${bindir} ${D}${sbindir} |
| 59 | |
| 60 | install -d ${D}${sysconfdir}/init.d |
| 61 | sed -e 's,/etc/,${sysconfdir}/,g' \ |
| 62 | -e 's,/sbin/,${sbindir}/,g' \ |
| 63 | ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind |
| 64 | chmod 0755 ${D}${sysconfdir}/init.d/rpcbind |
| 65 | |
| 66 | install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir} |
| 67 | install -d ${D}${systemd_unitdir}/system |
| 68 | install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system |
| 69 | install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system |
| 70 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ |
| 71 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 72 | ${D}${systemd_unitdir}/system/rpcbind.service |
| 73 | } |