Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Multiplexing terminal manager" |
| 2 | DESCRIPTION = "Screen is a full-screen window manager \ |
| 3 | that multiplexes a physical terminal between several \ |
| 4 | processes, typically interactive shells." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/screen/" |
| 6 | BUGTRACKER = "https://savannah.gnu.org/bugs/?func=additem&group=screen" |
| 7 | |
| 8 | SECTION = "console/utils" |
| 9 | |
| 10 | LICENSE = "GPLv3+" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 12 | file://screen.h;endline=26;md5=3971142989289a8198a544220703c2bf" |
| 13 | |
| 14 | DEPENDS = "ncurses \ |
| 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 16 | RDEPENDS_${PN} = "base-files" |
| 17 | |
| 18 | SRC_URI = "${GNU_MIRROR}/screen/screen-${PV}.tar.gz \ |
| 19 | file://fix-parallel-make.patch \ |
| 20 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://screen.pam', '', d)} \ |
| 21 | file://Remove-redundant-compiler-sanity-checks.patch \ |
| 22 | file://Provide-cross-compile-alternatives-for-AC_TRY_RUN.patch \ |
| 23 | file://Skip-host-file-system-checks-when-cross-compiling.patch \ |
| 24 | file://Avoid-mis-identifying-systems-as-SVR4.patch \ |
| 25 | file://0001-fix-for-multijob-build.patch \ |
| 26 | file://0002-comm.h-now-depends-on-term.h.patch \ |
| 27 | " |
| 28 | |
| 29 | SRC_URI[md5sum] = "5bb3b0ff2674e29378c31ad3411170ad" |
| 30 | SRC_URI[sha256sum] = "fa4049f8aee283de62e283d427f2cfd35d6c369b40f7f45f947dbfd915699d63" |
| 31 | |
| 32 | inherit autotools texinfo |
| 33 | |
| 34 | PACKAGECONFIG ??= "" |
| 35 | PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| 36 | |
| 37 | EXTRA_OECONF = "--with-pty-mode=0620 --with-pty-group=5 \ |
| 38 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)}" |
| 39 | |
| 40 | do_install_append () { |
| 41 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then |
| 42 | install -D -m 644 ${WORKDIR}/screen.pam ${D}/${sysconfdir}/pam.d/screen |
| 43 | fi |
| 44 | } |
| 45 | |
| 46 | pkg_postinst_${PN} () { |
| 47 | grep -q "^${bindir}/screen$" $D${sysconfdir}/shells || echo ${bindir}/screen >> $D${sysconfdir}/shells |
| 48 | } |
| 49 | |
| 50 | pkg_postrm_${PN} () { |
| 51 | printf "$(grep -v "^${bindir}/screen$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells |
| 52 | } |