Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl interface to the zlib compression library." |
| 2 | DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \ |
| 3 | to the zlib compression library (see 'AUTHOR' for details about where to \ |
| 4 | get zlib)." |
| 5 | HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=45bba5fa4937353fd4f505fa2108a6bf" |
| 10 | |
| 11 | SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz" |
| 12 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "46785a6a383a1c843895b7f9f25d5d759e7c305159f9d1e04a3604eb74c77374" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 14 | |
| 15 | DEPENDS += "zlib" |
| 16 | |
| 17 | S = "${WORKDIR}/Compress-Raw-Zlib-${PV}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
| 21 | export BUILD_ZLIB="0" |
| 22 | |
| 23 | do_compile() { |
| 24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 25 | cpan_do_compile |
| 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |