blob: 47fe8e0035bd020494e4cb2155702c63cf705893 [file] [log] [blame]
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05001SUMMARY = "Perl interface to the zlib compression library."
2DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \
3to the zlib compression library (see 'AUTHOR' for details about where to \
4get zlib)."
5HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib"
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
8
9LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=45bba5fa4937353fd4f505fa2108a6bf"
10
11SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz"
12
Patrick Williams2a254922023-08-11 09:48:11 -050013SRC_URI[sha256sum] = "46785a6a383a1c843895b7f9f25d5d759e7c305159f9d1e04a3604eb74c77374"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050014
15DEPENDS += "zlib"
16
17S = "${WORKDIR}/Compress-Raw-Zlib-${PV}"
18
19inherit cpan
20
21export BUILD_ZLIB="0"
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
28BBCLASSEXTEND = "native"