blob: 4b5e77e6e3147b5afeb9395967efeec5885d43c2 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003
4LICENSE = "MIT"
Patrick Williamsb542dec2023-06-09 01:26:37 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=0e5f41db57c3a8d3584b450d35985ad1"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006
7PYPI_PACKAGE = "ruamel.yaml"
8
9inherit pypi setuptools3
10
Andrew Geissler8f840682023-07-21 09:09:43 -050011SRC_URI[sha256sum] = "ec939063761914e14542972a5cba6d33c23b0859ab6342f61cf070cfc600efc2"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012
13RDEPENDS:${PN} += "\
14 ${PYTHON_PN}-shell \
15 ${PYTHON_PN}-datetime \
16 ${PYTHON_PN}-netclient \
17"
18
19do_install:prepend() {
20 export RUAMEL_NO_PIP_INSTALL_CHECK=1
21}
22
23BBCLASSEXTEND = "native nativesdk"