blob: 6ab7ab79dd6642767a7f2e0ebd584b6ba0cfd8d4 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
Brad Bishop63ae8782019-10-09 09:56:13 -040013DEPENDS = "libaio zlib coreutils-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
15RDEPENDS_${PN} = "python3-core bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
17PACKAGECONFIG_NUMA = "numa"
18# ARM does not currently support NUMA
19PACKAGECONFIG_NUMA_arm = ""
Brad Bishop34ae6002019-04-08 15:21:03 -040020PACKAGECONFIG_NUMA_armeb = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
23PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24
Andrew Geissler72956ed2021-01-08 16:11:14 -060025SRCREV = "fd80924b22fef6ce0d5580724d91490347445f90"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026SRC_URI = "git://git.kernel.dk/fio.git \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027"
28
29S = "${WORKDIR}/git"
30
31# avoids build breaks when using no-static-libs.inc
32DISABLE_STATIC = ""
33
34EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
37do_configure() {
38 ./configure ${EXTRA_OECONF}
39}
40
41do_install() {
42 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
43 install -d ${D}/${docdir}/${PN}
44 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
45}