Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer mixer library V2" |
| 2 | SECTION = "libs" |
| 3 | DEPENDS = "virtual/libsdl2 flac libmikmod libvorbis" |
| 4 | LICENSE = "Zlib" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=516daf7a177ad4c8874bb9efa1a69c1f" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-${PV}.tar.gz" |
| 8 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | SRC_URI[md5sum] = "a36e8410cac46b00a4d01752b32c3eb1" |
| 10 | SRC_URI[sha256sum] = "b4cf5a382c061cd75081cf246c2aa2f9df8db04bdda8dcdc6b6cca55bede2419" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/SDL2_mixer-${PV}" |
| 13 | |
| 14 | inherit autotools-brokensep pkgconfig |
| 15 | |
| 16 | EXTRA_AUTORECONF += "--include=acinclude" |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame^] | 17 | EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --disable-music-ogg-shared LIBS=-L${STAGING_LIBDIR}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | |
| 19 | PACKAGECONFIG[mad] = "--enable-music-mp3-mad-gpl,--disable-music-mp3-mad-gpl,libmad" |
| 20 | |
| 21 | do_configure_prepend () { |
| 22 | # Remove old libtool macros. |
| 23 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 24 | for i in ${MACROS}; do |
| 25 | rm -f acinclude/$i |
| 26 | done |
| 27 | } |