blob: 7cb0efbf976f352fe948c405625b309dfe9532a5 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "CSS selector library for python-beautifulsoup4"
2HOMEPAGE = "https://github.com/facelessuser/soupsieve"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5a6fd3b0c24fc5a041a3d1bbb22c81b5"
6
Andrew Geissler72956ed2021-01-08 16:11:14 -06007SRC_URI[sha256sum] = "6dc52924dc0bc710a5d16794e6b3480b2c7c08b07729505feab2b2c16661ff6e"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
Andrew Geissler748a4832020-07-24 16:24:21 -05009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-beautifulsoup4 \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25BBCLASSEXTEND = "native nativesdk"