Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "display dialog boxes from shell scripts" |
| 2 | DESCRIPTION = "Dialog lets you to present a variety of questions \ |
| 3 | or display messages using dialog boxes from a shell \ |
| 4 | script (or any scripting language)." |
| 5 | HOMEPAGE = "http://invisible-island.net/dialog/" |
| 6 | SECTION = "console/utils" |
| 7 | DEPENDS = "ncurses" |
| 8 | LICENSE = "LGPL-2.1-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 10 | |
| 11 | SRC_URI = "https://invisible-mirror.net/archives/${BPN}/${BP}.tgz" |
| 12 | SRC_URI[sha256sum] = "315640ab0719225d5cbcab130585c05f0791fcf073072a5fe9479969aa2b833b" |
| 13 | |
| 14 | # hardcoded here for use in dialog-static recipe |
| 15 | S = "${WORKDIR}/dialog-${PV}" |
| 16 | |
| 17 | inherit autotools-brokensep pkgconfig |
| 18 | |
| 19 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 20 | |
| 21 | PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11" |
| 22 | |
| 23 | EXTRA_OECONF = "--with-ncurses \ |
| 24 | --disable-rpath-hack" |
| 25 | |
| 26 | do_configure() { |
| 27 | gnu-configize --force |
| 28 | sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure |
| 29 | sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure |
| 30 | oe_runconf |
| 31 | } |