blob: 06aa30df053864ab803fc3d906ab792505142bec [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "https://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "\
9 git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http;;branch=master \
10 file://0001-client-Include-string.h-form-mem-function-prototypes.patch \
11 file://run-ptest \
12"
13
14SRCREV = "edfe78a0dc54a940f4916a9bd681eab7b3f746d1"
15
16LICENSE = "GPL-2.0-only"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
18
19S = "${WORKDIR}/git"
20
21inherit ptest
22
23COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
24
25EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
26
27do_compile() {
28 oe_runmake
29}
30
31do_install() {
32 oe_runmake install DESTDIR=${D}
33 install -d ${D}${sysconfdir}/cron.hourly
34 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
35 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
36}
37
38do_install_ptest() {
39 install -d ${D}${PTEST_PATH}
40 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
41 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
42}
43
44RDEPENDS:${PN}-ptest += "make bash mce-inject"