blob: fae1da2686778a1d404eec0ad8126baf915d99b9 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "jsonref is a library for automatic dereferencing of JSON Reference objects for Python"
2HOMEPAGE = "https://github.com/gazpachoking/jsonref"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ac1cccee5d43e11fc4eddcf445be64a"
5
6SRC_URI[sha256sum] = "32fe8e1d85af0fdefbebce950af85590b22b60f9e95443176adbde4e1ecea552"
7
8SRC_URI += "file://migrate-to-pdm-backend.patch"
9
10inherit pypi python_setuptools_build_meta
11
12BBCLASSEXTEND = "native nativesdk"
13
14DEPENDS += " \
15 ${PYTHON_PN}-pdm-native \
16 ${PYTHON_PN}-pdm-backend-native \
17"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23"