Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "jsonref is a library for automatic dereferencing of JSON Reference objects for Python" |
| 2 | HOMEPAGE = "https://github.com/gazpachoking/jsonref" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4ac1cccee5d43e11fc4eddcf445be64a" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "32fe8e1d85af0fdefbebce950af85590b22b60f9e95443176adbde4e1ecea552" |
| 7 | |
| 8 | SRC_URI += "file://migrate-to-pdm-backend.patch" |
| 9 | |
| 10 | inherit pypi python_setuptools_build_meta |
| 11 | |
| 12 | BBCLASSEXTEND = "native nativesdk" |
| 13 | |
| 14 | DEPENDS += " \ |
| 15 | ${PYTHON_PN}-pdm-native \ |
| 16 | ${PYTHON_PN}-pdm-backend-native \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | ${PYTHON_PN}-core \ |
| 21 | ${PYTHON_PN}-json \ |
| 22 | ${PYTHON_PN}-netclient \ |
| 23 | " |