blob: 86e4c6454fa5e8bbe0486dc4fbf4574e60ece0fa [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
5
6PYPI_PACKAGE = "ipython"
7
Patrick Williams73bd93f2024-02-20 08:07:48 -06008SRC_URI[sha256sum] = "48fbc236fbe0e138b88773fa0437751f14c3645fb483f1d4c5dee58b37e5ce73"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009
10RDEPENDS:${PN} = "\
11 ${PYTHON_PN}-setuptools \
12 ${PYTHON_PN}-jedi \
13 ${PYTHON_PN}-decorator \
14 ${PYTHON_PN}-pickleshare \
15 ${PYTHON_PN}-traitlets \
16 ${PYTHON_PN}-prompt-toolkit \
17 ${PYTHON_PN}-pygments \
18 ${PYTHON_PN}-backcall \
19 ${PYTHON_PN}-pydoc \
20 ${PYTHON_PN}-debugger \
21 ${PYTHON_PN}-pexpect \
22 ${PYTHON_PN}-unixadmin \
23 ${PYTHON_PN}-misc \
24 ${PYTHON_PN}-sqlite3 \
25 ${PYTHON_PN}-stack-data \
26"
27
28inherit setuptools3 pypi