Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)" |
| 2 | HOMEPAGE = "https://github.com/python/mypy" |
| 3 | LICENSE = "MIT & Python-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9" |
| 5 | |
| 6 | inherit pypi python_setuptools_build_meta |
| 7 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "6ff8b244d7085a0b425b56d327b480c3b29cafbd2eff27316a004f9a7391ae07" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 9 | |
| 10 | BBCLASSEXTEND = "native" |
| 11 | |
| 12 | DEPENDS += " \ |
| 13 | python3-mypy-extensions-native \ |
| 14 | python3-types-psutil-native \ |
| 15 | python3-types-setuptools-native \ |
| 16 | python3-typing-extensions-native \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | python3-modules \ |
| 21 | python3-mypy-extensions \ |
| 22 | python3-typing-extensions \ |
| 23 | " |