Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 1 | SUMMARY = "Python PE parsing module" |
| 2 | DESCRIPTION = "A multi-platform Python module to parse and work with Portable Executable (PE) files." |
| 3 | HOMEPAGE = "https://github.com/erocarrera/pefile" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38066667888b01d8118ff9cc23da1873" |
| 6 | |
| 7 | inherit setuptools3 pypi ptest |
| 8 | SRC_URI[sha256sum] = "82e6114004b3d6911c77c3953e3838654b04511b8b66e8583db70c65998017dc" |
| 9 | |
| 10 | PIP_INSTALL_PACKAGE = "pefile" |
| 11 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
| 12 | |
| 13 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 14 | |
| 15 | RDEPENDS:${PN} += " \ |
| 16 | python3-mmap \ |
| 17 | python3-netclient \ |
| 18 | python3-stringold \ |
| 19 | " |