blob: ba75057f59999a3ad6c9e967cef4b3678e13a7fb [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Python library for displaying tabular data in a ASCII table format"
2HOMEPAGE = "http://code.google.com/p/prettytable"
3LICENSE = "BSD-3-Clause"
Andrew Geissler220dafd2023-10-04 10:18:08 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=c9a6829fcd174d9535b46211917c7671"
Patrick Williams92b42cb2022-09-03 06:53:57 -05005
Andrew Geissler220dafd2023-10-04 10:18:08 -05006SRC_URI[sha256sum] = "f4ed94803c23073a90620b201965e5dc0bccf1760b7a7eaf3158cab8aaffdf34"
Patrick Williams92b42cb2022-09-03 06:53:57 -05007
8do_install:append() {
9 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
10 for f in $perm_files; do
11 chmod 644 "${f}"
12 done
13}
14
Patrick Williams92b42cb2022-09-03 06:53:57 -050015BBCLASSEXTEND = "native nativesdk"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060016inherit pypi ptest python_hatchling
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18SRC_URI += " \
19 file://run-ptest \
20"
21
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022DEPENDS += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060023 python3-hatch-vcs-native \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060024"
Patrick Williams92b42cb2022-09-03 06:53:57 -050025
26RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060027 python3-math \
28 python3-html \
29 python3-wcwidth \
30 python3-json \
31 python3-compression \
32 python3-importlib-metadata \
Patrick Williams92b42cb2022-09-03 06:53:57 -050033"
34
35RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060036 python3-pytest \
37 python3-pytest-lazy-fixture \
38 python3-sqlite3 \
39 python3-unittest-automake-output \
Patrick Williams92b42cb2022-09-03 06:53:57 -050040"
41
42do_install_ptest() {
43 cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/
44}