blob: 618aba4a67c5e034af99d2115af7787ba4990d82 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library for Python 3.6+ to communicate with the Google Chromecast."
2HOMEPAGE = "https://github.com/balloob/pychromecast"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006SRC_URI[sha256sum] = "08e61a8b54bd2119d3c9ab1ec0136d3d8563aa97e0a3b57841588b9be60c2676"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8PYPI_PACKAGE = "PyChromecast"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-logging \
14 ${PYTHON_PN}-zeroconf \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-protobuf \
18 ${PYTHON_PN}-compression \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 ${PYTHON_PN}-casttube \
Andrew Geissler517393d2023-01-13 08:55:19 -060020"