Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library" |
| 2 | DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library" |
| 3 | HOMEPAGE = "https://github.com/pyca/pynacl" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba" |
| 8 | |
| 9 | PYPI_PACKAGE = "PyNaCl" |
| 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "\ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | ${PYTHON_PN}-cffi-native \ |
| 15 | libsodium \ |
| 16 | " |
| 17 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | do_compile:prepend() { |
| 19 | export SODIUM_INSTALL=system |
| 20 | } |
| 21 | |
| 22 | do_install:prepend() { |
| 23 | export SODIUM_INSTALL=system |
| 24 | } |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 25 | |
| 26 | RDEPENDS:${PN} = "\ |
| 27 | ${PYTHON_PN}-six \ |
| 28 | ${PYTHON_PN}-cffi \ |
| 29 | libsodium \ |
| 30 | " |
| 31 | |
| 32 | RPROVIDES:${PN} = "python3-nacl" |
| 33 | |
| 34 | # in meta-virtualization layer |
| 35 | # |
| 36 | RCONFLICTS:${PN} = "python3-nacl" |