blob: 0747c67c19fa9a7b79506879835310f550520e11 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
2DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
3HOMEPAGE = "https://github.com/pyca/pynacl"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
6
7SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
8
9PYPI_PACKAGE = "PyNaCl"
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011inherit pypi python_setuptools_build_meta
Andrew Geissler595f6302022-01-24 19:11:47 +000012
13DEPENDS += "\
Andrew Geissler595f6302022-01-24 19:11:47 +000014 ${PYTHON_PN}-cffi-native \
15 libsodium \
16"
17
Andrew Geissler595f6302022-01-24 19:11:47 +000018do_compile:prepend() {
19 export SODIUM_INSTALL=system
20}
21
22do_install:prepend() {
23 export SODIUM_INSTALL=system
24}
Patrick Williamsac13d5f2023-11-24 18:59:46 -060025
26RDEPENDS:${PN} = "\
27 ${PYTHON_PN}-six \
28 ${PYTHON_PN}-cffi \
29 libsodium \
30"
31
32RPROVIDES:${PN} = "python3-nacl"
33
34# in meta-virtualization layer
35#
36RCONFLICTS:${PN} = "python3-nacl"