blob: 5793db55f66a6345174587503e8d690f73431b79 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "PyZMQ: Python bindings for ZMQ"
2DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation."
3HOMEPAGE = "http://zeromq.org/bindings:python"
4LICENSE = "BSD-3-Clause & LGPL-3.0-only"
5LIC_FILES_CHKSUM = "\
Andrew Geissler220dafd2023-10-04 10:18:08 -05006 file://LICENSE.BSD;md5=1787206f198344195a671b60326c59dc \
7 file://LICENSE.LESSER;md5=0e99bfbdd8b9d33b0221986fe3be89ed \
Patrick Williams92b42cb2022-09-03 06:53:57 -05008"
9
Andrew Geissler220dafd2023-10-04 10:18:08 -050010DEPENDS = "python3-packaging-native python3-cython-native python3-setuptools-scm-native zeromq"
Patrick Williams92b42cb2022-09-03 06:53:57 -050011
12SRC_URI:append = " \
13 file://club-rpath-out.patch \
14 file://run-ptest \
15"
Patrick Williams169d7bc2024-01-05 11:33:25 -060016SRC_URI[sha256sum] = "93f1aa311e8bb912e34f004cf186407a4e90eec4f0ecc0efd26056bf7eda0226"
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18inherit pypi pkgconfig python_setuptools_build_meta ptest
19
20PACKAGES =+ "\
21 ${PN}-test \
22"
23
24FILES:${PN}-test += "\
25 ${libdir}/${PYTHON_DIR}/site-packages/*/tests \
26"
27
28RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060029 python3-json \
30 python3-multiprocessing \
Patrick Williams92b42cb2022-09-03 06:53:57 -050031"
32
33RDEPENDS:${PN}-ptest += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060034 ${PN}-test \
35 python3-pytest \
36 python3-unittest-automake-output \
Patrick Williams92b42cb2022-09-03 06:53:57 -050037"
38
39do_compile:prepend() {
40 echo [global] > ${S}/setup.cfg
41 echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg
42 echo have_sys_un_h = True >> ${S}/setup.cfg
43 echo skip_check_zmq = True >> ${S}/setup.cfg
44 echo libzmq_extension = False >> ${S}/setup.cfg
45 echo no_libzmq_extension = True >> ${S}/setup.cfg
46}
47
Andrew Geissler87f5cff2022-09-30 13:13:31 -050048do_install:append() {
49 sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/config.json
50 sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/compiler.json
51}
52
Patrick Williams92b42cb2022-09-03 06:53:57 -050053do_install_ptest() {
54 install -d ${D}${PTEST_PATH}/tests
55 cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/
56}