Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 1 | SUMMARY = "Improved build system generator for Python C/C++/Fortran/Cython extensions" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc" |
| 4 | |
| 5 | DEPENDS = "${PYTHON_PN}-hatch-vcs-native ${PYTHON_PN}-hatch-fancy-pypi-readme-native" |
| 6 | |
| 7 | PYPI_PACKAGE = "scikit_build" |
| 8 | |
| 9 | inherit pypi python_hatchling |
| 10 | |
| 11 | SRC_URI[sha256sum] = "b51a51a36b37c42650994b5047912f59b22e3210b23e321f287611f9ef6e5c9d" |
| 12 | |
| 13 | RDEPENDS:${PN} = " \ |
| 14 | ${PYTHON_PN}-distro \ |
| 15 | ${PYTHON_PN}-packaging \ |
| 16 | ${PYTHON_PN}-setuptools \ |
| 17 | ${PYTHON_PN}-typing-extensions \ |
| 18 | ${PYTHON_PN}-wheel \ |
| 19 | cmake \ |
| 20 | " |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |