blob: af2c4a1e2e2d282127df1ce537cac06a574a97b7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A simple, safe single expression evaluator library"
2HOMEPAGE = "https://pypi.org/project/simpleeval/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
5
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06006SRC_URI[sha256sum] = "4a30f9cc01825fe4c719c785e3762623e350c4840d5e6855c2a8496baaa65fac"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10BBCLASSEXTEND = "native nativesdk"
11
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060012SRC_URI += "file://run-ptest"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-math \
Andrew Geissler595f6302022-01-24 19:11:47 +000016"
17
18RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-pytest \
20 python3-unittest-automake-output \
Andrew Geissler595f6302022-01-24 19:11:47 +000021"
22
Andrew Geissler595f6302022-01-24 19:11:47 +000023do_install_ptest() {
24 cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
25}