blob: b6e04e081e043cbeaa04f0d3a6003cfd2ebe5e51 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPL-2.0-or-later"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https"
9SRCREV = "9b6a83a7aef546ddacafcc656984c9bbed67a8ec"
10
11S = "${WORKDIR}/git"
12
13inherit features_check setuptools3
14REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data"
15
16PIP_INSTALL_PACKAGE = "blivet_gui"
17
18RDEPENDS:${PN} = "python3-pygobject python3 \
19 python3-blivet gtk+3 \
20 python3-pid libreport \
21"
22
23FILES:${PN} += "${datadir}/*"