Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "GUI tool for storage configuration using blivet library" |
| 2 | HOMEPAGE = "https://github.com/rhinstaller/blivet-gui" |
| 3 | LICENSE = "GPL-2.0-or-later" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=main;protocol=https" |
| 9 | SRCREV = "9b6a83a7aef546ddacafcc656984c9bbed67a8ec" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit features_check setuptools3 |
| 14 | REQUIRED_DISTRO_FEATURES = "x11 systemd gobject-introspection-data" |
| 15 | |
| 16 | PIP_INSTALL_PACKAGE = "blivet_gui" |
| 17 | |
| 18 | RDEPENDS:${PN} = "python3-pygobject python3 \ |
| 19 | python3-blivet gtk+3 \ |
| 20 | python3-pid libreport \ |
| 21 | " |
| 22 | |
| 23 | FILES:${PN} += "${datadir}/*" |