blob: 9ea30754821069ff1c061d177401e01715f0fe61 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006DEPENDS += "openssl python3-cryptography"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06007
Patrick Williams73bd93f2024-02-20 08:07:48 -06008SRC_URI[sha256sum] = "6aa33039a93fffa4563e655b61d11364d01264be8ccb49906101e02a334530bf"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060017 python3-cryptography \
18 python3-six \
19 python3-threading \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"