Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | HOMEPAGE = "https://lttng.org/" |
| 5 | LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4" |
| 7 | |
| 8 | inherit module |
| 9 | |
| 10 | include lttng-platforms.inc |
| 11 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 12 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 13 | file://0001-Fix-sched_stat_runtime-changed-in-linux-6.8.0-rc1.patch \ |
| 14 | file://0002-Fix-timer_start-changed-in-linux-6.8.0-rc1.patch \ |
| 15 | file://0003-Fix-strlcopy-removed-in-linux-6.8.0-rc1.patch \ |
| 16 | file://0004-Fix-btrfs_chunk-tracepoints-changed-in-linux-6.8.0-r.patch \ |
| 17 | file://0005-Fix-btrfs_get_extent-flags-and-compress_type-changed.patch \ |
| 18 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 19 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 20 | # Use :append here so that the patch is applied also when using devupstream |
| 21 | SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch" |
| 22 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 23 | SRC_URI[sha256sum] = "297211d6fda459c85793c1f498c90fad2939cda7939d503f3ec5eaaf5fbec3c7" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 24 | |
| 25 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 26 | |
| 27 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 28 | |
| 29 | MODULES_MODULE_SYMVERS_LOCATION = "src" |
| 30 | |
| 31 | do_install:append() { |
| 32 | # Delete empty directories to avoid QA failures if no modules were built |
| 33 | if [ -d ${D}/${nonarch_base_libdir} ]; then |
| 34 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 35 | fi |
| 36 | } |
| 37 | |
| 38 | python do_package:prepend() { |
| 39 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 40 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "devupstream:target" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 44 | SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13;protocol=https" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 45 | SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630" |
| 46 | SRCREV_FORMAT ?= "lttng_git" |