Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Error - Error/exception handling in an OO-ish way" |
| 2 | DESCRIPTION = "The Error package provides two interfaces. Firstly \ |
| 3 | Error provides a procedural interface to exception handling. \ |
| 4 | Secondly Error is a base class for errors/exceptions that can \ |
| 5 | either be thrown, for subsequent catch, or can simply be recorded." |
| 6 | |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100" |
| 11 | |
| 12 | DEPENDS += "perl" |
| 13 | |
| 14 | SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[md5sum] = "0dcd94640f617df02b6d6c1e4e92018c" |
| 17 | SRC_URI[sha256sum] = "37590a962cd73ae03470e1ff16459a6cbc5273fc57626b8981dab9c2433155d9" |
| 18 | |
| 19 | S = "${WORKDIR}/Error-${PV}" |
| 20 | |
| 21 | inherit cpan ptest-perl |
| 22 | |
| 23 | do_compile() { |
| 24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 25 | cpan_do_compile |
| 26 | } |
| 27 | |
| 28 | do_install_prepend() { |
| 29 | # test requires "-T" (taint) command line option |
| 30 | rm -rf ${B}/t/pod-coverage.t |
| 31 | } |
| 32 | |
| 33 | BBCLASSEXTEND = "native" |