blob: d59379fd2b92982485e585ef9c9b36d41bb146b2 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Tool to produce a statistics based on a diff"
2DESCRIPTION = "diffstat reads the output of diff and displays a histogram of \
3the insertions, deletions, and modifications per-file. It is useful for \
4reviewing large, complex patch files."
5HOMEPAGE = "http://invisible-island.net/diffstat/"
6SECTION = "devel"
7LICENSE = "MIT"
Patrick Williams73bd93f2024-02-20 08:07:48 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=5713b4719a66a6527e6301e8f8745877"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
11 file://run-ptest \
12 file://avoid-check-user-break-cc.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 "
14
Patrick Williams73bd93f2024-02-20 08:07:48 -060015SRC_URI[sha256sum] = "f54531bbe32e8e0fa461f018b41e3af516b632080172f361f05e50367ecbb69e"
Andrew Geissler706d5aa2021-02-12 15:55:30 -060016
Andrew Geissler82c905d2020-04-13 13:39:40 -050017inherit autotools gettext ptest
18
19EXTRA_AUTORECONF += "--exclude=aclocal"
20
21LDFLAGS += "${TOOLCHAIN_OPTIONS}"
22
23do_install_ptest() {
24 cp -r ${S}/testing ${D}${PTEST_PATH}
25}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060026
27BBCLASSEXTEND = "nativesdk"