blob: 9ca41e650b05d1ddfc01bf4bc97c1ae98445cf1f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
Andrew Geissler1fe918a2020-05-15 14:16:47 -05007SRCREV = "1dde9d94e0848e12da20602ca38032b91d521427"
Brad Bishopc342db32019-05-15 21:57:59 -04008
9SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.4 \
10 file://run-ptest \
11"
12
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig ptest
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
19
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040020DISABLE_STATIC = ""
21
Brad Bishopc342db32019-05-15 21:57:59 -040022do_compile_ptest() {
23 oe_runmake -C tests check-build
24}
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 install -d ${D}${PTEST_PATH}/tools
29 for file in $(find tests/* -executable -type f); do
30 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
31 done
32 for file in $(find tests/*.tests -type f); do
33 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
34 done
35 for file in $(find tools/* -executable -type f); do
36 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
37 done
38}
39
40FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
41FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
42
43RDEPENDS_${PN}-ptest = "bash"