Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Control Software for VCU" |
| 2 | DESCRIPTION = "Control software libraries, test applications and headers provider for VCU" |
| 3 | LICENSE = "Proprietary" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493" |
| 5 | |
| 6 | XILINX_VCU_VERSION = "1.0.0" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 7 | PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" |
| 8 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 9 | BRANCH ?= "release-2020.1" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 10 | REPO ?= "git://github.com/xilinx/vcu-ctrl-sw.git;protocol=https" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 11 | SRCREV ?= "8ad2b1323bdc98d580360e1a01006d70625c4e65" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 12 | |
| 13 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 14 | SRC_URI = "${REPO};${BRANCHARG}" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | COMPATIBLE_MACHINE = "^$" |
| 19 | COMPATIBLE_MACHINE_zynqmp = "zynqmp" |
| 20 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 21 | PACKAGE_ARCH = "${SOC_FAMILY_ARCH}" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 22 | |
| 23 | RDEPENDS_${PN} = "kernel-module-vcu" |
| 24 | |
| 25 | EXTRA_OEMAKE = "CC='${CC}' CXX='${CXX} ${CXXFLAGS}'" |
| 26 | |
| 27 | do_install() { |
| 28 | install -d ${D}${libdir} |
| 29 | install -d ${D}${includedir}/vcu-ctrl-sw/include |
| 30 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | install -Dm 0755 ${S}/bin/ctrlsw_encoder ${D}/${bindir}/ctrlsw_encoder |
| 32 | install -Dm 0755 ${S}/bin/ctrlsw_decoder ${D}/${bindir}/ctrlsw_decoder |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 33 | |
| 34 | oe_runmake install_headers INSTALL_HDR_PATH=${D}${includedir}/vcu-ctrl-sw/include |
| 35 | oe_libinstall -C ${S}/bin/ -so liballegro_decode ${D}/${libdir}/ |
| 36 | oe_libinstall -C ${S}/bin/ -so liballegro_encode ${D}/${libdir}/ |
| 37 | } |
| 38 | |
| 39 | # These libraries shouldn't get installed in world builds unless something |
| 40 | # explicitly depends upon them. |
| 41 | |
| 42 | EXCLUDE_FROM_WORLD = "1" |