Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenMAX Integration layer for VCU" |
| 2 | DESCRIPTION = "OMX IL Libraries,test applications and headers for VCU" |
| 3 | LICENSE = "Proprietary" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493" |
| 5 | |
| 6 | XILINX_VCU_VERSION = "1.0.0" |
Brad Bishop | 754b8fa | 2019-08-20 09:16:20 -0400 | [diff] [blame^] | 7 | XILINX_RELEASE_VERSION = "v2019.1" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 8 | PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" |
| 9 | |
Brad Bishop | 754b8fa | 2019-08-20 09:16:20 -0400 | [diff] [blame^] | 10 | BRANCH ?= "master-rel-2019.1" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 11 | REPO ?= "git://github.com/xilinx/vcu-omx-il.git;protocol=https" |
Brad Bishop | 754b8fa | 2019-08-20 09:16:20 -0400 | [diff] [blame^] | 12 | SRCREV ?= "b93cec02cd5da223fa965073dce130a08ffd6419" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 13 | |
| 14 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 15 | SRC_URI = "${REPO};${BRANCHARG}" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | COMPATIBLE_MACHINE = "^$" |
| 20 | COMPATIBLE_MACHINE_zynqmp = "zynqmp" |
| 21 | |
| 22 | PACKAGE_ARCH = "${SOC_FAMILY}" |
| 23 | |
| 24 | DEPENDS = "libvcu-xlnx" |
| 25 | RDEPENDS_${PN} = "kernel-module-vcu libvcu-xlnx" |
| 26 | |
| 27 | EXTERNAL_INCLUDE="${STAGING_INCDIR}/vcu-ctrl-sw/include" |
| 28 | |
| 29 | EXTRA_OEMAKE = " \ |
| 30 | CC='${CC}' CXX='${CXX} ${CXXFLAGS}' \ |
| 31 | EXTERNAL_INCLUDE='${EXTERNAL_INCLUDE}' \ |
| 32 | " |
| 33 | |
| 34 | do_install() { |
| 35 | install -d ${D}${libdir} |
| 36 | install -d ${D}${includedir}/vcu-omx-il |
| 37 | |
| 38 | install -m 0644 ${S}/omx_header/*.h ${D}${includedir}/vcu-omx-il |
| 39 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | install -Dm 0755 ${S}/bin/omx_decoder ${D}/${bindir}/omx_decoder |
| 41 | install -Dm 0755 ${S}/bin/omx_encoder ${D}/${bindir}/omx_encoder |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 42 | |
| 43 | oe_libinstall -C ${S}/bin/ -so libOMX.allegro.core ${D}/${libdir}/ |
| 44 | oe_libinstall -C ${S}/bin/ -so libOMX.allegro.video_decoder ${D}/${libdir}/ |
| 45 | oe_libinstall -C ${S}/bin/ -so libOMX.allegro.video_encoder ${D}/${libdir}/ |
| 46 | } |
| 47 | |
| 48 | # These libraries shouldn't get installed in world builds unless something |
| 49 | # explicitly depends upon them. |
| 50 | |
| 51 | EXCLUDE_FROM_WORLD = "1" |