Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require gstreamer1.0-plugins.inc |
| 2 | |
| 3 | SRC_URI = " \ |
| 4 | http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 5 | file://0001-scaletempo-Advertise-interleaved-layout-in-caps-temp.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ |
| 7 | " |
| 8 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 9 | SRC_URI[md5sum] = "d1a7b442994d9522418de4af4330e034" |
| 10 | SRC_URI[sha256sum] = "654adef33380d604112f702c2927574cfc285e31307b79e584113858838bb0fd" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/gst-plugins-good-${PV}" |
| 13 | |
| 14 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 16 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \ |
| 17 | file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe" |
| 18 | |
| 19 | DEPENDS += "gstreamer1.0-plugins-base libcap" |
| 20 | RPROVIDES_${PN}-pulseaudio += "${PN}-pulse" |
| 21 | RPROVIDES_${PN}-soup += "${PN}-souphttpsrc" |
| 22 | |
| 23 | inherit gettext |
| 24 | |
| 25 | PACKAGECONFIG ??= " \ |
| 26 | ${GSTREAMER_ORC} \ |
| 27 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \ |
| 28 | bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 zlib \ |
| 29 | " |
| 30 | |
| 31 | X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage" |
| 32 | |
| 33 | PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2" |
| 34 | PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo" |
| 35 | PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394" |
| 36 | PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac" |
| 37 | PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf" |
| 38 | PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3" |
| 39 | PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev" |
| 40 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" |
| 41 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 42 | PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame" |
| 43 | PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng" |
| 44 | PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils" |
| 45 | PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123" |
| 46 | PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio" |
| 47 | PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4" |
| 48 | PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex" |
| 49 | PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib" |
| 50 | PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2" |
| 51 | PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx" |
| 52 | PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack" |
| 53 | PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}" |
| 54 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib" |
| 55 | |
| 56 | # qt5 support is disabled, because it is not present in OE core, and requires more work than |
| 57 | # just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths). |
| 58 | # This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig |
| 59 | # in a gstreamer1.0-plugins-good bbappend). |
| 60 | |
| 61 | EXTRA_OECONF += " \ |
| 62 | --enable-oss \ |
| 63 | --disable-aalib \ |
| 64 | --disable-aalibtest \ |
| 65 | --disable-directsound \ |
| 66 | --disable-libcaca \ |
| 67 | --disable-libdv \ |
| 68 | --disable-oss4 \ |
| 69 | --disable-osx_audio \ |
| 70 | --disable-osx_video \ |
| 71 | --disable-qt \ |
| 72 | --disable-shout2 \ |
| 73 | --disable-twolame \ |
| 74 | --disable-waveform \ |
| 75 | " |
| 76 | |
| 77 | FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" |