Ashwin Murali | 321eb03 | 2022-04-29 14:47:15 -0500 | [diff] [blame] | 1 | SUMMARY = "Initialize PWM sensors" |
| 2 | DESCRIPTION = "Initialize PWM sensors" |
| 3 | LICENSE = "CLOSED" |
Kyle Nieman | aefbb65 | 2023-06-30 10:57:34 -0500 | [diff] [blame] | 4 | DEPENDS:append = " systemd" |
Ashwin Murali | 321eb03 | 2022-04-29 14:47:15 -0500 | [diff] [blame] | 5 | PR = "r1" |
| 6 | |
Kyle Nieman | aefbb65 | 2023-06-30 10:57:34 -0500 | [diff] [blame] | 7 | SRC_URI = " \ |
| 8 | file://pwm_init.service \ |
| 9 | file://bin/pwm_init.sh \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | SYSTEMD_AUTO_ENABLE = "enable" |
| 14 | SYSTEMD_SERVICE:${PN} = " pwm_init.service" |
| 15 | |
Ashwin Murali | 321eb03 | 2022-04-29 14:47:15 -0500 | [diff] [blame] | 16 | inherit systemd |
| 17 | |
Kyle Nieman | aefbb65 | 2023-06-30 10:57:34 -0500 | [diff] [blame] | 18 | do_install() { |
Ashwin Murali | 321eb03 | 2022-04-29 14:47:15 -0500 | [diff] [blame] | 19 | install -d ${D}${libexecdir}/${PN} |
| 20 | install -m 0755 ${S}/bin/* ${D}${libexecdir}/${PN}/ |
| 21 | install -d ${D}${systemd_system_unitdir} |
| 22 | install -m 0644 ${S}/*.service ${D}${systemd_system_unitdir} |
| 23 | } |
Kyle Nieman | aefbb65 | 2023-06-30 10:57:34 -0500 | [diff] [blame] | 24 | |
| 25 | RDEPENDS:${PN}:append = " bash" |
| 26 | |
| 27 | FILES:${PN}:append = " ${bindir}/* ${systemd_system_unitdir}/*" |