Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Displays the full path of shell commands" |
| 2 | DESCRIPTION = "Which is a utility that prints out the full path of the \ |
| 3 | executables that bash(1) would execute when the passed \ |
| 4 | program names would have been entered on the shell prompt. \ |
| 5 | It does this by using the exact same algorithm as bash." |
| 6 | SECTION = "libs" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 7 | HOMEPAGE = "https://carlowood.github.io/which/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | LICENSE = "GPL-3.0-or-later" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\ |
| 11 | file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2" |
| 12 | DEPENDS = "cwautomacros-native" |
| 13 | |
| 14 | inherit autotools texinfo update-alternatives |
| 15 | |
| 16 | PR = "r3" |
| 17 | |
| 18 | EXTRA_OECONF = "--disable-iberty" |
| 19 | |
| 20 | SRC_URI = "${GNU_MIRROR}/which/which-${PV}.tar.gz \ |
| 21 | file://automake.patch \ |
| 22 | " |
| 23 | |
| 24 | SRC_URI[md5sum] = "097ff1a324ae02e0a3b0369f07a7544a" |
| 25 | SRC_URI[sha256sum] = "f4a245b94124b377d8b49646bf421f9155d36aa7614b6ebf83705d3ffc76eaad" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | do_configure:prepend() { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am |
| 29 | } |
| 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | ALTERNATIVE:${PN} = "which" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | ALTERNATIVE_PRIORITY = "100" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | ALTERNATIVE:${PN}-doc = "which.1" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 35 | ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 36 | |
| 37 | BBCLASSEXTEND = "nativesdk" |