Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Basic desktop integration functions" |
| 2 | HOMEPAGE = "https://www.freedesktop.org/wiki/Software/xdg-utils/" |
| 3 | DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \ |
| 4 | desktop integration functions for any Free Desktop, such as Linux. \ |
| 5 | They are intended to provide a set of defacto standards. \ |
| 6 | The following scripts are provided at this time: \ |
| 7 | xdg-desktop-icon \ |
| 8 | xdg-desktop-menu \ |
| 9 | xdg-email \ |
| 10 | xdg-icon-resource \ |
| 11 | xdg-mime \ |
| 12 | xdg-open \ |
| 13 | xdg-screensaver \ |
| 14 | xdg-terminal \ |
| 15 | " |
| 16 | |
| 17 | LICENSE = "MIT" |
| 18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014" |
| 19 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | SRC_URI = "https://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | file://0001-Reinstate-xdg-terminal.patch \ |
| 22 | file://0001-Don-t-build-the-in-script-manual.patch \ |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 23 | file://1f199813e0eb0246f63b54e9e154970e609575af.patch \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 24 | file://CVE-2022-4055.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | " |
| 26 | |
| 27 | SRC_URI[md5sum] = "902042508b626027a3709d105f0b63ff" |
| 28 | SRC_URI[sha256sum] = "d798b08af8a8e2063ddde6c9fa3398ca81484f27dec642c5627ffcaa0d4051d9" |
| 29 | |
| 30 | UPSTREAM_CHECK_REGEX = "xdg-utils-(?P<pver>((\d+[\.\-_]*)+)((rc|alpha|beta)\d+)?)\.(tar\.gz|tgz)" |
| 31 | |
| 32 | # Needs brokensep as this doesn't use automake |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 33 | inherit autotools-brokensep features_check |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | |
| 35 | # The xprop requires x11 in DISTRO_FEATURES |
| 36 | REQUIRED_DISTRO_FEATURES = "x11" |
| 37 | |
| 38 | DEPENDS = "xmlto-native libxslt-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | RDEPENDS:${PN} += "xprop" |