blob: 7d90ac3612fdbeb3cbe10571bc3aff564a8fd15d [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Patrick Williamse760df82023-05-26 11:10:49 -050014PACKAGECONFIG ??= "scripting tui libunwind libtraceevent"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Patrick Williams2390b1b2022-11-03 13:47:49 -050016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3 python3-setuptools-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
Patrick Williams92b42cb2022-09-03 06:53:57 -050023PACKAGECONFIG[bfd] = ",NO_LIBBFD=1"
Joel Stanleye252c312017-12-14 15:11:12 +103024PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
25PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026# libaudit support would need scripting to be enabled
27PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
Brad Bishop64c979e2019-11-04 13:55:29 -050029PACKAGECONFIG[cap] = ",,libcap"
Patrick Williamse760df82023-05-26 11:10:49 -050030PACKAGECONFIG[libtraceevent] = ",NO_LIBTRACEEVENT=1,libtraceevent"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050031# Arm CoreSight
32PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34# libunwind is not yet ported for some architectures
Patrick Williams213cb262021-08-07 19:21:33 -050035PACKAGECONFIG:remove:arc = "libunwind"
Patrick Williams213cb262021-08-07 19:21:33 -050036PACKAGECONFIG:remove:riscv32 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040037
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038DEPENDS = " \
39 virtual/${MLPREFIX}libc \
40 ${MLPREFIX}elfutils \
41 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040042 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043"
44
45do_configure[depends] += "virtual/kernel:do_shared_workdir"
46
47PROVIDES = "virtual/perf"
48
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050
51# needed for building the tools/perf Python bindings
Patrick Williams325e4992023-05-04 11:08:58 -050052inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3targetconfig', '', d)}
Brad Bishop79641f22019-09-10 07:20:22 -040053inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054export PYTHON_SITEPACKAGES_DIR
55
56#kernel 3.1+ supports WERROR to disable warnings as errors
57export WERROR = "0"
58
Andrew Geissler82c905d2020-04-13 13:39:40 -050059do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050060
61# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080062include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063
64inherit kernelsrc
65
Brad Bishop316dfdd2018-06-25 12:45:53 -040066S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067SPDX_S = "${S}/tools/perf"
68
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069# The LDFLAGS is required or some old kernels fails due missing
70# symbols and this is preferred than requiring patches to every old
71# supported kernel.
72LDFLAGS="-ldl -lutil"
73
74EXTRA_OEMAKE = '\
Andrew Geissler635e0e42020-08-21 15:58:33 -050075 V=1 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050076 -C ${S}/tools/perf \
77 O=${B} \
78 CROSS_COMPILE=${TARGET_PREFIX} \
79 ARCH=${ARCH} \
80 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050081 CCLD="${CC}" \
82 LDSHARED="${CC} -shared" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060084 LD="${LD}" \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050085 EXTRA_CFLAGS="-ldw -I${S}" \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050086 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
Joel Stanleye252c312017-12-14 15:11:12 +103087 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050088 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080089 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103090 ${PACKAGECONFIG_CONFARGS} \
Patrick Williamse760df82023-05-26 11:10:49 -050091 PKG_CONFIG=pkg-config \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080092 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040093 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050094'
95
96EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050097 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050098 'prefix=${prefix}' \
99 'bindir=${bindir}' \
100 'sharedir=${datadir}' \
101 'sysconfdir=${sysconfdir}' \
102 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
104 'sharedir=${@os.path.relpath(datadir, prefix)}' \
105 'mandir=${@os.path.relpath(mandir, prefix)}' \
106 'infodir=${@os.path.relpath(infodir, prefix)}' \
Brad Bishop79641f22019-09-10 07:20:22 -0400107 ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500108"
109
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700110# During do_configure, we might run a 'make clean'. That often breaks
111# when done in parallel, so disable parallelism for do_configure. Note
112# that it has to be done this way rather than by passing -j1, since
113# perf's build system by default ignores any -j argument, but does
114# honour a JOBS variable.
Patrick Williams213cb262021-08-07 19:21:33 -0500115EXTRA_OEMAKE:append:task-configure = " JOBS=1"
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700116
Brad Bishop316dfdd2018-06-25 12:45:53 -0400117PERF_SRC ?= "Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400118 tools/arch \
119 tools/build \
120 tools/include \
121 tools/lib \
122 tools/Makefile \
123 tools/perf \
124 tools/scripts \
Brad Bishop64c979e2019-11-04 13:55:29 -0500125 scripts/ \
126 arch/${ARCH}/Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400127"
128
Joel Stanleye252c312017-12-14 15:11:12 +1030129PERF_EXTRA_LDFLAGS = ""
130
Andrew Geissler595f6302022-01-24 19:11:47 +0000131# MIPS N32/N64
Patrick Williams213cb262021-08-07 19:21:33 -0500132PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32"
133PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32"
Andrew Geissler595f6302022-01-24 19:11:47 +0000134PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip"
135PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip"
Joel Stanleye252c312017-12-14 15:11:12 +1030136
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500137do_compile() {
138 # Linux kernel build system is expected to do the right thing
139 unset CFLAGS
Patrick Williamsb542dec2023-06-09 01:26:37 -0500140 test -e ${S}/tools/lib/traceevent/plugins/Makefile && \
141 sed -i -e 's|\$(libdir)/traceevent/plugins|\$(libdir)/traceevent_${KERNEL_VERSION}/plugins|g' ${S}/tools/lib/traceevent/plugins/Makefile
142 test -e ${S}/tools/perf/Makefile.config && \
143 sed -i -e 's|\$(libdir)/traceevent/plugins|\$(libdir)/traceevent_${KERNEL_VERSION}/plugins|g' ${S}/tools/perf/Makefile.config
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 oe_runmake all
145}
146
147do_install() {
148 # Linux kernel build system is expected to do the right thing
149 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500150 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500151 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030152 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Brad Bishop79641f22019-09-10 07:20:22 -0400153 oe_runmake DESTDIR=${D} install-python_ext
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500154 if [ -e ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt ]; then
155 sed -i -e 's#${WORKDIR}##g' ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt
156 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500157 fi
158}
159
Brad Bishop316dfdd2018-06-25 12:45:53 -0400160do_configure[prefuncs] += "copy_perf_source_from_kernel"
161python copy_perf_source_from_kernel() {
162 sources = (d.getVar("PERF_SRC") or "").split()
163 src_dir = d.getVar("STAGING_KERNEL_DIR")
164 dest_dir = d.getVar("S")
165 bb.utils.mkdirhier(dest_dir)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500166 bb.utils.prunedir(dest_dir)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400167 for s in sources:
168 src = oe.path.join(src_dir, s)
169 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800170 if not os.path.exists(src):
171 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400172 if os.path.isdir(src):
173 oe.path.copyhardlinktree(src, dest)
174 else:
Brad Bishop64c979e2019-11-04 13:55:29 -0500175 src_path = os.path.dirname(s)
176 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400177 bb.utils.copyfile(src, dest)
178}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179
Patrick Williams213cb262021-08-07 19:21:33 -0500180do_configure:prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500181 # If building a multlib based perf, the incorrect library path will be
182 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700183 # build, with a 64 bit multilib, the arch won't match and the detection of a
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500184 # 64 bit build (and library) are not exected. To ensure that libraries are
185 # installed to the correct location, we can use the weak assignment in the
186 # config/Makefile.
187 #
188 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
189 # for kernel sources that do not already do this
190 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
191 # with each other if its in the shared source directory
192 #
193 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600194 perfconfig="${S}/tools/perf/config/Makefile"
195 fi
196 if [ -e "${S}/tools/perf/Makefile.config" ]; then
197 perfconfig="${S}/tools/perf/Makefile.config"
198 fi
199 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500200 # Match $(prefix)/$(lib) and $(prefix)/lib
201 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
202 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
203 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600204 ${perfconfig}
205 fi
206 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
207 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
208 # will use the relative path 'share/man', in the way it will resulting in
209 # incorrect installation for man pages.
210 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
211 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500212 fi
213 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
214 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
215 ${S}/tools/perf/Makefile.perf
Patrick Williams92b42cb2022-09-03 06:53:57 -0500216 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='\$(DESTDIR)',g" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500217 ${S}/tools/perf/Makefile.perf
Andrew Geissler635e0e42020-08-21 15:58:33 -0500218 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8
219 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \
220 ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500221 fi
222 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500223 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500224
225 if [ -e "${S}/tools/build/Makefile.build" ]; then
226 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
227 ${S}/tools/build/Makefile.build
228 fi
229
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500230 # start reproducibility substitutions
231 if [ -e "${S}/tools/perf/Makefile.config" ]; then
232 # The following line in the Makefle:
233 # override PYTHON := $(call get-executable-or-default,PYTHON,$(PYTHON_AUTO))
234 # "PYTHON" / "PYTHON_AUTO" have the full path as part of the variable. We've
235 # ensure that the environment is setup and we do not need the full path to be
236 # captured, since the symbol gets built into the executable, making it not
237 # reproducible.
238 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \
239 ${S}/tools/perf/Makefile.config
Patrick Williamsdb4c27e2022-08-05 08:10:29 -0500240 # The same line is in older releases, but looking explicitly for Python 2
241 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON2)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON2))),g' \
242 ${S}/tools/perf/Makefile.config
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500243
Andrew Geissler615f2f12022-07-15 14:00:58 -0500244 # likewise with this substitution. Kernels with commit 18f2967418d031a39
245 # [perf tools: Use Python devtools for version autodetection rather than runtime]
246 # need this substitution for reproducibility.
247 sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO))),$(notdir $(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO)))),g' \
248 ${S}/tools/perf/Makefile.config
249
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500250 # The following line:
251 # srcdir_SQ = $(patsubst %tools/perf,tools/perf,$(subst ','\'',$(srcdir))),
252 # Captures the full src path of perf, which of course makes it not
253 # reproducible. We really only need the relative location 'tools/perf', so we
254 # change the Makefile line to remove everything before 'tools/perf'
255 sed -i -e "s%srcdir_SQ = \$(subst ','\\\'',\$(srcdir))%srcdir_SQ = \$(patsubst \%tools/perf,tools/perf,\$(subst ','\\\'',\$(srcdir)))%g" \
256 ${S}/tools/perf/Makefile.config
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500257 # Avoid hardcoded path to python-native
258 sed -i -e 's#\(PYTHON_WORD := \)$(call shell-wordify,$(PYTHON))#\1 python3#g' \
259 ${S}/tools/perf/Makefile.config
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500260 fi
261 if [ -e "${S}/tools/perf/tests/Build" ]; then
262 # OUTPUT is the full path, we have python on the path so we remove it from the
263 # definition. This is captured in the perf binary, so breaks reproducibility
264 sed -i -e 's,PYTHONPATH="BUILD_STR($(OUTPUT)python)",PYTHONPATH="BUILD_STR(python)",g' \
265 ${S}/tools/perf/tests/Build
266 fi
267 if [ -e "${S}/tools/perf/util/Build" ]; then
268 # To avoid bison generating #ifdefs that have captured paths, we make sure
269 # all the calls have YFLAGS, which contains prefix mapping information.
270 sed -i -e 's,$(BISON),$(BISON) $(YFLAGS),g' ${S}/tools/perf/util/Build
271 fi
272 if [ -e "${S}/scripts/Makefile.host" ]; then
273 # To avoid yacc (bison) generating #ifdefs that have captured paths, we make sure
274 # all the calls have YFLAGS, which contains prefix mapping information.
275 sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host
276 fi
277 if [ -e "${S}/tools/perf/pmu-events/Build" ]; then
278 target='$(OUTPUT)pmu-events/pmu-events.c $(V)'
279 replacement1='$(OUTPUT)pmu-events/pmu-events.c $(V)\n'
280 replacement2='\t$(srctree)/sort-pmuevents.py $(OUTPUT)pmu-events/pmu-events.c $(OUTPUT)pmu-events/pmu-events.c.new\n'
281 replacement3='\tcp $(OUTPUT)pmu-events/pmu-events.c.new $(OUTPUT)pmu-events/pmu-events.c'
282 sed -i -e "s,$target,$replacement1$replacement2$replacement3,g" \
283 "${S}/tools/perf/pmu-events/Build"
284 fi
Patrick Williams864cc432023-02-09 14:54:44 -0600285 if [ -e "${S}/tools/perf/pmu-events/jevents.py" ]; then
286 sed -i -e "s#os.scandir(path)#sorted(os.scandir(path), key=lambda e: e.name)#g" \
287 "${S}/tools/perf/pmu-events/jevents.py"
288 fi
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500289 if [ -e "${S}/tools/perf/arch/arm64/Makefile" ]; then
290 sed -i 's,sysdef := $(srctree)/,sysdef := ,' ${S}/tools/perf/arch/arm64/Makefile
291 sed -i 's,$(incpath) $(sysdef),$(incpath) $(srctree)/$(sysdef) $(sysdef),' ${S}/tools/perf/arch/arm64/Makefile
292 fi
293 if [ -e "${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl" ]; then
294 if ! grep -q input_rel ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl; then
295 sed -i 's,input=$4,input=$4\ninput_rel=$5,' ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl
296 fi
297 sed -i 's,#include \\"\$input\\",#include \\"\$input_rel\\",' ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl
298 fi
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500299 # end reproducibility substitutions
300
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500301 # We need to ensure the --sysroot option in CC is preserved
302 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
303 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
304 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600305 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamse760df82023-05-26 11:10:49 -0500306 sed -i 's,PKG_CONFIG = $(CROSS_COMPILE)pkg-config,#PKG_CONFIG,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500307 fi
308 if [ -e "${S}/tools/lib/api/Makefile" ]; then
309 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
310 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600311 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500312 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500313 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
314 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
315 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
316 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500317 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
318 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
319 fi
320 if [ -e "${S}/tools/build/Makefile.feature" ]; then
321 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
322 fi
323
324 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
325 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
326 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
327 fi
328 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
329 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
330 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
331 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500332
333 # use /usr/bin/env instead of version specific python
Andrew Geissler82c905d2020-04-13 13:39:40 -0500334 for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do
335 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500336 done
Brad Bishop19323692019-04-05 15:28:33 -0400337
338 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
339 # so we copy it from the sysroot unistd.h to the perf unistd.h
Brad Bishopc342db32019-05-15 21:57:59 -0400340 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Brad Bishop79641f22019-09-10 07:20:22 -0400341 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
Andrew Geissler95ac1b82021-03-31 14:34:31 -0500342
343 # the fetcher is inhibited by the 'inherit kernelsrc', so we do a quick check and
344 # copy for a helper script we need
345 for p in $(echo ${FILESPATH} | tr ':' '\n'); do
346 if [ -e $p/sort-pmuevents.py ]; then
347 cp $p/sort-pmuevents.py ${S}
348 fi
349 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500350}
351
Patrick Williams213cb262021-08-07 19:21:33 -0500352python do_package:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500353 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500354}
355
356PACKAGE_ARCH = "${MACHINE_ARCH}"
357
358
359PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
360
Patrick Williams213cb262021-08-07 19:21:33 -0500361RDEPENDS:${PN} += "elfutils bash"
362RDEPENDS:${PN}-archive =+ "bash"
363RDEPENDS:${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
364RDEPENDS:${PN}-perl =+ "bash perl perl-modules"
365RDEPENDS:${PN}-tests =+ "python3 bash"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500366
Joel Stanleye252c312017-12-14 15:11:12 +1030367RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williams213cb262021-08-07 19:21:33 -0500368RSUGGESTS:${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500369
Brad Bishop19323692019-04-05 15:28:33 -0400370FILES_SOLIBSDEV = ""
Patrick Williamsb542dec2023-06-09 01:26:37 -0500371FILES:${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent* ${libdir}/libperf-jvmti.so"
Patrick Williams213cb262021-08-07 19:21:33 -0500372FILES:${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
373FILES:${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
374FILES:${PN}-python = " \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400375 ${PYTHON_SITEPACKAGES_DIR} \
376 ${libexecdir}/perf-core/scripts/python \
377 "
Patrick Williams213cb262021-08-07 19:21:33 -0500378FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500379
Patrick Williams213cb262021-08-07 19:21:33 -0500380DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
Patrick Williams864cc432023-02-09 14:54:44 -0600381
382PACKAGESPLITFUNCS =+ "perf_fix_sources"
383
384perf_fix_sources () {
385 for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \
Andrew Geissler8f840682023-07-21 09:09:43 -0500386 util/pmu-flex.h util/expr-flex.h util/expr-flex.c; do
Patrick Williams864cc432023-02-09 14:54:44 -0600387 f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f
388 if [ -e $f ]; then
389 sed -i -e 's#${S}/##g' $f
390 fi
391 done
392}