George Liu | d335b65 | 2024-06-03 19:09:16 +0800 | [diff] [blame] | 1 | SUMMARY = "IEISystems OEM IPMI commands" |
| 2 | DESCRIPTION = "IEISystems OEM IPMI commands" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 6 | |
| 7 | SRC_URI = "git://github.com/openbmc/iei-ipmi-oem;branch=master;protocol=https" |
Andrew Geissler | 7655ae8 | 2024-06-05 01:40:03 -0500 | [diff] [blame^] | 8 | SRCREV = "b4396f2321f9420b190fdd4438bb5503a9b5b7de" |
George Liu | d335b65 | 2024-06-03 19:09:16 +0800 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | PV = "0.1+git${SRCPV}" |
| 12 | |
| 13 | DEPENDS += "phosphor-ipmi-host" |
| 14 | DEPENDS += "phosphor-logging" |
| 15 | |
| 16 | inherit meson pkgconfig |
| 17 | inherit obmc-phosphor-ipmiprovider-symlink |
| 18 | |
| 19 | PACKAGECONFIG ??= "" |
| 20 | |
| 21 | FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 22 | FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 23 | FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 24 | FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}" |