Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Text::Diff - Perform diffs on files and record sets" |
| 2 | DESCRIPTION = "diff() provides a basic set of services akin to the GNU diff \ |
| 3 | utility. It is not anywhere near as feature complete as GNU diff, but it is \ |
| 4 | better integrated with Perl and available on all platforms. It is often \ |
| 5 | faster than shelling out to a system's diff executable for small files, \ |
| 6 | and generally slower on larger files." |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/" |
| 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | LICENSE = "Artistic-1.0 | GPL-2.0-or-later" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3" |
| 13 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 14 | SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz \ |
| 15 | file://run-ptest \ |
| 16 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21" |
| 18 | SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa" |
| 19 | |
| 20 | S = "${WORKDIR}/Text-Diff-${PV}" |
| 21 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 22 | inherit cpan ptest |
| 23 | RDEPENDS:${PN}-ptest += "perl-module-test perl-module-test-more" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | RDEPENDS:${PN} = " libalgorithm-diff-perl \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | perl-module-extutils-makemaker \ |
| 27 | perl-module-exporter \ |
| 28 | " |
| 29 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 30 | do_install_ptest () { |
| 31 | cp -r ${B}/t ${D}${PTEST_PATH} |
| 32 | } |
| 33 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 34 | BBCLASSEXTEND = "native" |