blob: 9dfadde8e5cc577fc1628a0673d37d29bc8187eb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Text::Diff - Perform diffs on files and record sets"
2DESCRIPTION = "diff() provides a basic set of services akin to the GNU diff \
3utility. It is not anywhere near as feature complete as GNU diff, but it is \
4better integrated with Perl and available on all platforms. It is often \
5faster than shelling out to a system's diff executable for small files, \
6and generally slower on larger files."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/"
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "Artistic-1.0 | GPL-2.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
13
Patrick Williamsac13d5f2023-11-24 18:59:46 -060014SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz \
15 file://run-ptest \
16 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21"
18SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa"
19
20S = "${WORKDIR}/Text-Diff-${PV}"
21
Patrick Williamsac13d5f2023-11-24 18:59:46 -060022inherit cpan ptest
23RDEPENDS:${PN}-ptest += "perl-module-test perl-module-test-more"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN} = " libalgorithm-diff-perl \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026 perl-module-extutils-makemaker \
27 perl-module-exporter \
28"
29
Patrick Williamsac13d5f2023-11-24 18:59:46 -060030do_install_ptest () {
31 cp -r ${B}/t ${D}${PTEST_PATH}
32}
33
Patrick Williamsb48b7b42016-08-17 15:04:38 -050034BBCLASSEXTEND = "native"