Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Security-focused ELF files checking tool" |
| 2 | DESCRIPTION = "This is a small set of various PaX aware and related \ |
| 3 | utilities for ELF binaries. It can check ELF binary files and running \ |
| 4 | processes for issues that might be relevant when using ELF binaries \ |
| 5 | along with PaX, such as non-PIC code or executable stack and heap." |
| 6 | HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 9 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | SRC_URI = "https://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "eeca7fbd98bc66bead4a77000c2025d9f17ea8201b84245882406ce00b9b6b14" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} += "bash" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | |
| 15 | export GNULIB_OVERRIDES_WINT_T = "0" |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | do_configure:prepend() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install |
| 23 | } |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |
| 26 | |
| 27 | inherit autotools pkgconfig |
| 28 | |
| 29 | PACKAGECONFIG ??= "" |
| 30 | |
| 31 | PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap" |
| 32 | PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp" |
| 33 | PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools" |
| 34 | |
| 35 | EXTRA_OECONF += "--enable-largefile" |