Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux SCSi tools to service maintain disk storage devices" |
| 2 | DESCRIPTION = "scsirastools were designed to add to the Serviceability of \ |
| 3 | SCSI devices under Linux so that the system does not have \ |
| 4 | to be rebooted or taken out of service to perform common \ |
| 5 | maintenance or service functions. It handles SCSI, \ |
| 6 | Linux SW RAID, SAS, SATA, and USB devices via SCSI emulation." |
| 7 | HOMEPAGE = "http://scsirastools.sourceforge.net/" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 8 | LICENSE = "BSD-3-Clause" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=687ea108478d26152ae46eb29d9d1545" |
| 10 | |
| 11 | DEPENDS += "groff-native" |
| 12 | |
| 13 | SRC_URI = "http://prdownloads.sourceforge.net/scsirastools/scsirastools-${PV}.tar.gz \ |
| 14 | file://mdadm.patch;apply=no \ |
| 15 | file://print-format.patch \ |
| 16 | " |
| 17 | SRC_URI[md5sum] = "6271a61b2ce40aaf33ef61775148cda1" |
| 18 | SRC_URI[sha256sum] = "e7b997e75decb06a650c42c35cd63d0c94c34e39cf133c723337b0eeabbfdf6a" |
| 19 | |
| 20 | inherit autotools update-rc.d |
| 21 | |
| 22 | # mdadm Makefile has CC set to gcc, hence override CC to ${CC} |
| 23 | EXTRA_OEMAKE += "CC='${CC}'" |
| 24 | |
| 25 | |
| 26 | do_configure_append() { |
| 27 | oe_runmake -C mdadm.d mdadm-1.3.0 |
| 28 | patch -p0 < ${WORKDIR}/mdadm.patch |
| 29 | } |
| 30 | INITSCRIPT_PACKAGES = "${PN}-diskmon ${PN}-raidmon" |
| 31 | INITSCRIPT_NAME_${PN}-diskmon = "sgdisk" |
| 32 | INITSCRIPT_PARAMS_${PN}-diskmon = "defaults 80 20" |
| 33 | INITSCRIPT_NAME_${PN}-raidmon = "sgraid" |
| 34 | INITSCRIPT_PARAMS_${PN}-raidmon = "defaults 80 20" |
| 35 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | PACKAGES =+ "${PN}-diskmon" |
| 37 | PACKAGES =+ "${PN}-raidmon" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | RPROVIDES_${PN}-dbg += "${PN}-diskmon-dbg ${PN}-raidmon-dbg" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | |
| 41 | FILES_${PN}-diskmon = "${sbindir}/sgdiskmon ${sysconfdir}/init.d/sgdisk" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 42 | |
| 43 | FILES_${PN}-raidmon = "${sbindir}/sgraidmon ${sysconfdir}/init.d/sgraid" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 44 | |
| 45 | RDEPENDS_${PN} += "bash" |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 46 | RDEPENDS_${PN}-diskmon += "${PN} bash" |
| 47 | RDEPENDS_${PN}-raidmon += "${PN} bash" |