Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "LDAP Perl module" |
| 2 | DESCRIPTION = "Net::LDAP is a collection of modules that implements \ |
| 3 | a LDAP services API for Perl programs. The module may be used to \ |
| 4 | search directories or perform maintenance functions such as adding, \ |
| 5 | deleting or modifying entries." |
| 6 | |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "Artistic-1.0|GPLv1+" |
| 10 | LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e" |
| 11 | |
| 12 | SRC_URI = "${CPAN_MIRROR}/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz" |
| 13 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 14 | SRC_URI[md5sum] = "d091ed00302f0276069bca9df9478744" |
| 15 | SRC_URI[sha256sum] = "e2f389fe3e7a9e4b61488692919ad723b98f3b479b5288f610daa8c27995b351" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/perl-ldap-${PV}" |
| 18 | |
| 19 | inherit cpan ptest-perl |
| 20 | |
| 21 | do_configure_prepend() { |
| 22 | perl -pi -e 's/auto_install_now.*//g' Makefile.PL |
| 23 | } |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | cp -r ${B}/data ${D}${PTEST_PATH} |
| 27 | chown -R root:root ${D}${PTEST_PATH} |
| 28 | } |
| 29 | |
| 30 | RDEPENDS_${PN} += " \ |
| 31 | libconvert-asn1-perl \ |
| 32 | libio-socket-ssl-perl \ |
| 33 | libauthen-sasl-perl \ |
| 34 | perl-module-integer \ |
| 35 | " |
| 36 | |
| 37 | RDEPENDS_${PN}-ptest += " \ |
| 38 | libxml-sax-base-perl \ |
| 39 | libxml-sax-writer-perl \ |
| 40 | perl-module-file-compare \ |
| 41 | perl-module-perlio \ |
| 42 | perl-module-test-more \ |
| 43 | " |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |