Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | DESCRIPTION = "Selection of tools for developers working with Smack" |
| 2 | HOMEPAGE = "https://github.com/smack-team/smack" |
| 3 | SECTION = "Security/Access Control" |
| 4 | LICENSE = "LGPL-2.1" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 7 | |
| 8 | SRCREV = "4a102c7584b39ce693995ffb65e0918a9df98dd8" |
| 9 | SRC_URI = " \ |
| 10 | git://github.com/smack-team/smack.git \ |
| 11 | file://smack_generator_make_fixup.patch \ |
| 12 | file://run-ptest" |
| 13 | |
| 14 | PV = "1.3.1" |
| 15 | |
Andrew Geissler | a1a6aef | 2021-06-25 14:23:58 -0500 | [diff] [blame] | 16 | # CVE-2014-0363, CVE-2014-0364, CVE-2016-10027 is valnerble for other product. |
| 17 | CVE_CHECK_WHITELIST += "CVE-2014-0363" |
| 18 | CVE_CHECK_WHITELIST += "CVE-2014-0364" |
| 19 | CVE_CHECK_WHITELIST += "CVE-2016-10027" |
| 20 | |
Brad Bishop | a48c014 | 2020-01-06 09:48:41 -0500 | [diff] [blame] | 21 | inherit autotools update-rc.d pkgconfig ptest |
| 22 | inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} |
| 23 | inherit features_check |
| 24 | |
| 25 | REQUIRED_DISTRO_FEATURES = "smack" |
| 26 | |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 27 | |
| 28 | S = "${WORKDIR}/git" |
| 29 | |
| 30 | PACKAGECONFIG ??= "" |
| 31 | PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
| 32 | |
| 33 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, --without-systemdsystemunitdir, systemd" |
| 34 | |
| 35 | do_compile_append () { |
| 36 | oe_runmake -C ${S}/tests generator |
| 37 | } |
| 38 | |
| 39 | do_install_append () { |
| 40 | install -d ${D}${sysconfdir}/init.d |
| 41 | install -d ${D}${sysconfdir}/smack |
| 42 | install -d ${D}${sysconfdir}/smack/accesses.d |
| 43 | install -d ${D}${sysconfdir}/smack/cipso.d |
| 44 | install ${S}/init/smack.rc ${D}/${sysconfdir}/init.d/smack |
| 45 | } |
| 46 | |
| 47 | do_install_ptest () { |
| 48 | install -d ${D}${PTEST_PATH}/tests |
| 49 | install ${S}/tests/generator ${D}/${PTEST_PATH}/tests |
| 50 | install ${S}/tests/generate-rules.sh ${D}${PTEST_PATH}/tests |
| 51 | install ${S}/tests/make_policies.bash ${D}${PTEST_PATH}/tests |
| 52 | } |
| 53 | |
| 54 | INITSCRIPT_PACKAGES = "${PN}" |
| 55 | INITSCRIPT_NAME = "smack" |
| 56 | INITSCRIPT_PARAMS = "start 16 2 3 4 5 . stop 35 0 1 6 ." |
| 57 | |
| 58 | FILES_${PN} += "${sysconfdir}/init.d/smack" |
| 59 | FILES_${PN}-ptest += "generator" |
| 60 | |
Brad Bishop | 36166cd | 2019-08-26 01:31:32 -0400 | [diff] [blame] | 61 | RDEPENDS_${PN} += "coreutils python3-core" |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 62 | RDEPENDS_${PN}-ptest += "make bash bc" |
| 63 | |
| 64 | BBCLASSEXTEND = "native" |