Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 2 | DESCRIPTION = "Software package manager that installs, updates, and removes \ |
| 3 | packages on RPM-based Linux distributions. It automatically computes \ |
| 4 | dependencies and determines the actions required to install packages." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 5 | HOMEPAGE = "https://github.com/rpm-software-management/dnf" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI = "git://github.com/rpm-software-management/dnf.git \ |
| 12 | file://0001-Corretly-install-tmpfiles.d-configuration.patch \ |
| 13 | file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \ |
| 14 | file://0005-Do-not-prepend-installroot-to-logdir.patch \ |
| 15 | file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
| 16 | file://0030-Run-python-scripts-using-env.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://0001-set-python-path-for-completion_helper.patch \ |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 18 | file://0001-dnf-write-the-log-lock-to-root.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | " |
| 20 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 21 | SRCREV = "e7b29753dce94769d30f92e671f55863985d24f0" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit cmake gettext bash-completion distutils3-base systemd |
| 27 | |
| 28 | DEPENDS += "libdnf librepo libcomps python3-iniparse" |
| 29 | |
| 30 | # manpages generation requires http://www.sphinx-doc.org/ |
| 31 | EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |
| 34 | |
| 35 | RDEPENDS_${PN} += " \ |
| 36 | python3-core \ |
| 37 | python3-codecs \ |
| 38 | python3-netclient \ |
| 39 | python3-email \ |
| 40 | python3-threading \ |
| 41 | python3-distutils \ |
| 42 | python3-logging \ |
| 43 | python3-fcntl \ |
| 44 | librepo \ |
| 45 | python3-shell \ |
| 46 | libcomps \ |
| 47 | libdnf \ |
| 48 | python3-sqlite3 \ |
| 49 | python3-compression \ |
| 50 | python3-rpm \ |
| 51 | python3-iniparse \ |
| 52 | python3-json \ |
| 53 | python3-curses \ |
| 54 | python3-misc \ |
| 55 | python3-gpg \ |
| 56 | " |
| 57 | |
| 58 | RDEPENDS_${PN}_class-native = "" |
| 59 | |
| 60 | RRECOMMENDS_${PN}_class-target += "gnupg" |
| 61 | |
| 62 | # Create a symlink called 'dnf' as 'make install' does not do it, but |
| 63 | # .spec file in dnf source tree does (and then Fedora and dnf documentation |
| 64 | # says that dnf binary is plain 'dnf'). |
| 65 | do_install_append() { |
| 66 | lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf |
| 67 | lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic |
| 68 | } |
| 69 | |
| 70 | # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in |
| 71 | do_install_append_class-native() { |
| 72 | create_wrapper ${D}/${bindir}/dnf \ |
| 73 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ |
| 74 | RPM_NO_CHROOT_FOR_SCRIPTS=1 |
| 75 | } |
| 76 | |
| 77 | do_install_append_class-nativesdk() { |
| 78 | create_wrapper ${D}/${bindir}/dnf \ |
| 79 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \ |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 80 | RPM_NO_CHROOT_FOR_SCRIPTS=1 |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 81 | } |
| 82 | |
| 83 | SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \ |
| 84 | dnf-automatic.service dnf-automatic.timer \ |
| 85 | dnf-automatic-download.service dnf-automatic-download.timer \ |
| 86 | dnf-automatic-install.service dnf-automatic-install.timer \ |
| 87 | dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \ |
| 88 | " |
| 89 | SYSTEMD_AUTO_ENABLE ?= "disable" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 90 | |
| 91 | PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}" |