Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Pre generated host keys mainly for speeding up our qemu tests" |
| 2 | |
| 3 | SRC_URI = "file://dropbear_rsa_host_key \ |
| 4 | file://openssh" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 8 | |
| 9 | INHIBIT_DEFAULT_DEPS = "1" |
| 10 | |
| 11 | do_install () { |
| 12 | install -d ${D}${sysconfdir}/dropbear |
| 13 | install ${WORKDIR}/dropbear_rsa_host_key -m 0600 ${D}${sysconfdir}/dropbear/ |
| 14 | |
| 15 | install -d ${D}${sysconfdir}/ssh |
| 16 | install ${WORKDIR}/openssh/* ${D}${sysconfdir}/ssh/ |
| 17 | chmod 0600 ${D}${sysconfdir}/ssh/* |
| 18 | chmod 0644 ${D}${sysconfdir}/ssh/*.pub |
| 19 | } |