Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | HOMEPAGE = "https://pypi.org/project/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | |
| 9 | SRC_URI += "file://0001-change-shebang-to-python3.patch" |
| 10 | SRC_URI += "file://no_shebang_mangling.patch" |
| 11 | SRC_URI += "file://reproducible.patch" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "f29d589df8c8ab99c060e68ad294c4a9ed896624f6368c5349d70aa581b333d0" |
| 14 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 15 | do_install:append() { |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 16 | rm -f ${D}/${bindir}/pip |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 17 | } |
| 18 | |
| 19 | RDEPENDS:${PN} = "\ |
| 20 | python3-compile \ |
| 21 | python3-io \ |
| 22 | python3-html \ |
| 23 | python3-json \ |
| 24 | python3-multiprocessing \ |
| 25 | python3-netserver \ |
| 26 | python3-setuptools \ |
| 27 | python3-unixadmin \ |
| 28 | python3-xmlrpc \ |
| 29 | python3-pickle \ |
| 30 | " |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 33 | |
| 34 | # This used to use the bootstrap install which didn't compile. Until we bump the |
| 35 | # tmpdir version we can't compile the native otherwise the sysroot unpack fails |
| 36 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |