Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order." |
| 2 | HOMEPAGE = "https://pypi.org/project/ruamel.yaml/" |
| 3 | AUTHOR = "Anthon van der Neut" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=034154b7344d15438bc5ed5ee9cc075f" |
| 7 | |
| 8 | PYPI_PACKAGE = "ruamel.yaml" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | SRC_URI[sha256sum] = "8b7ce697a2f212752a35c1ac414471dc16c424c9573be4926b56ff3f5d23b7af" |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | ${PYTHON_PN}-shell \ |
| 16 | ${PYTHON_PN}-datetime \ |
| 17 | ${PYTHON_PN}-netclient \ |
| 18 | " |
| 19 | |
| 20 | do_install:prepend() { |
| 21 | export RUAMEL_NO_PIP_INSTALL_CHECK=1 |
| 22 | } |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |