Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "The tpm-tools package contains commands to allow the platform administrator the ability to manage and diagnose the platform's TPM." |
| 2 | DESCRIPTION = " \ |
| 3 | The tpm-tools package contains commands to allow the platform administrator \ |
| 4 | the ability to manage and diagnose the platform's TPM. Additionally, the \ |
| 5 | package contains commands to utilize some of the capabilities available \ |
| 6 | in the TPM PKCS#11 interface implemented in the openCryptoki project. \ |
| 7 | " |
| 8 | SECTION = "tpm" |
| 9 | LICENSE = "CPL-1.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=059e8cd6165cb4c31e351f2b69388fd9" |
| 11 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | DEPENDS = "libtspi openssl perl-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | DEPENDS:class-native = "trousers-native" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 15 | SRCREV = "bf43837575c5f7d31865562dce7778eae970052e" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | SRC_URI = " \ |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 17 | git://git.code.sf.net/p/trousers/tpm-tools;branch=master \ |
Andrew Geissler | 59125e0 | 2021-07-23 12:56:22 -0400 | [diff] [blame] | 18 | file://tpm-tools-extendpcr.patch \ |
| 19 | file://04-fix-FTBFS-clang.patch \ |
| 20 | file://openssl1.1_fix.patch \ |
| 21 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | |
| 23 | inherit autotools-brokensep gettext |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | do_configure:prepend () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | mkdir -p po |
| 29 | mkdir -p m4 |
| 30 | cp -R po_/* po/ |
| 31 | touch po/Makefile.in.in |
| 32 | touch m4/Makefile.am |
| 33 | } |
| 34 | |
| 35 | BBCLASSEXTEND = "native" |