Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 1 | require recipes-devtools/atp/atp-source_3.1.inc |
2 | inherit package | ||||
3 | |||||
4 | SUMMARY = "End-to-end tests evaluating ATP kernel modules service correctness" | ||||
5 | SECTION = "kernel/userland" | ||||
6 | |||||
7 | S = "${WORKDIR}/git" | ||||
8 | SRC_URI = "${ATP_SRC}" | ||||
9 | |||||
10 | EXTRA_OEMAKE += "-C linux/test" | ||||
11 | |||||
12 | do_compile() { | ||||
13 | oe_runmake | ||||
14 | } | ||||
15 | |||||
16 | do_install() { | ||||
17 | oe_runmake DESTDIR=${D} PREFIX=${prefix} install | ||||
18 | } | ||||
19 | |||||
20 | DEPENDS = "atp-uapi cppunit" | ||||
21 | RDEPENDS:${PN} = "atp-uapi" |