Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "HTTP/2 C Library and tools" |
| 2 | HOMEPAGE = "https://nghttp2.org/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | SRC_URI = "\ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 8 | ${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | file://0001-fetch-ocsp-response-use-python3.patch \ |
| 10 | " |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 11 | SRC_URI[sha256sum] = "af24007e34c18c782393a1dc3685f8fd5b50283e90a9191d25488eb50aa2c825" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 13 | inherit cmake manpages python3native github-releases |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | PACKAGECONFIG[manpages] = "" |
| 15 | |
| 16 | # examples are never installed, and don't need to be built in the |
| 17 | # first place |
| 18 | EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF" |
| 19 | |
| 20 | PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server" |
| 21 | |
| 22 | RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})" |
| 23 | RDEPENDS:${PN}:class-native = "" |
| 24 | RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell" |
| 25 | |
| 26 | ALLOW_EMPTY:${PN} = "1" |
| 27 | FILES:${PN} = "" |
| 28 | FILES:lib${BPN} = "${libdir}/*${SOLIBS}" |
| 29 | FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp" |
| 30 | FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response" |
| 31 | FILES:${PN}-server = "${bindir}/nghttpd" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |