Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ISC Kea DHCP Server" |
| 2 | DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS." |
| 3 | HOMEPAGE = "http://kea.isc.org" |
| 4 | SECTION = "connectivity" |
| 5 | LICENSE = "MPL-2.0 & Apache-2.0" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=2ed44ce4e0bbfdc1abfa6bf949b7ba3a" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | |
| 8 | DEPENDS += "kea-native" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \ |
| 12 | file://0003-Makefile.am-update-hooksdir-for-lease_cmds.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 13 | file://0001-remove-AC_TRY_RUN.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | file://kea-dhcp4.service \ |
| 15 | file://kea-dhcp6.service \ |
| 16 | file://kea-dhcp-ddns.service \ |
| 17 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 18 | SRC_URI[md5sum] = "591d38e5fcc0251a8812e8bb1337578a" |
| 19 | SRC_URI[sha256sum] = "edce4fab68ca7af607cf7f5bc86596e04fe0ef4b8e88906e339cdefcf21daaec" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | |
| 21 | inherit autotools systemd |
| 22 | |
| 23 | SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" |
| 24 | SYSTEMD_AUTO_ENABLE = "disable" |
| 25 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 26 | DEBUG_OPTIMIZATION_remove_mips = " -Og" |
| 27 | DEBUG_OPTIMIZATION_append_mips = " -O" |
| 28 | BUILD_OPTIMIZATION_remove_mips = " -Og" |
| 29 | BUILD_OPTIMIZATION_append_mips = " -O" |
| 30 | |
| 31 | DEBUG_OPTIMIZATION_remove_mipsel = " -Og" |
| 32 | DEBUG_OPTIMIZATION_append_mipsel = " -O" |
| 33 | BUILD_OPTIMIZATION_remove_mipsel = " -Og" |
| 34 | BUILD_OPTIMIZATION_append_mipsel = " -O" |
| 35 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | do_configure_prepend_class-target() { |
| 37 | mkdir -p ${B}/src/lib/log/compiler/ |
| 38 | ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler |
| 39 | } |
| 40 | |
| 41 | do_install_append_class-target() { |
| 42 | install -d ${D}${systemd_system_unitdir} |
| 43 | install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir} |
| 44 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 45 | -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 46 | ${D}${systemd_system_unitdir}/kea-dhcp*service |
| 47 | } |
| 48 | |
| 49 | do_install_append() { |
| 50 | rm -rf "${D}${localstatedir}" |
| 51 | } |
| 52 | |
| 53 | PACKAGECONFIG ??= "openssl log4cplus boost" |
| 54 | |
| 55 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl" |
| 56 | PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus" |
| 57 | PACKAGECONFIG[boost] = "--with-boost-include=${STAGING_INCDIR} --with-boost-lib-dir=${STAGING_LIBDIR} --with-boost-libs=-lboost_system,,boost,boost" |
| 58 | |
| 59 | FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a" |
| 60 | FILES_${PN} += "${libdir}/hooks/*.so" |
| 61 | |
| 62 | BBCLASSEXTEND += "native" |