Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP and WebDAV client library with a C interface" |
| 2 | HOMEPAGE = "http://www.webdav.org/neon/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://src/COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a \ |
| 6 | file://src/ne_utils.h;beginline=1;endline=20;md5=2caca609538eddaa6f6adf120a218037" |
| 7 | DEPENDS = "zlib libxml2 expat time gnutls libproxy" |
| 8 | DEPENDS_class-native = "zlib-native libxml2-native expat-native gnutls-native" |
| 9 | |
| 10 | BBCLASSEXTEND = "native" |
| 11 | |
| 12 | SRC_URI = "http://www.webdav.org/${BPN}/${BPN}-${PV}.tar.gz \ |
| 13 | file://pkgconfig.patch \ |
| 14 | file://gnutls_4.3_fixup.patch" |
| 15 | SRC_URI[md5sum] = "231adebe5c2f78fded3e3df6e958878e" |
| 16 | SRC_URI[sha256sum] = "00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd" |
| 17 | |
| 18 | BINCONFIG = "${bindir}/neon-config" |
| 19 | |
| 20 | inherit autotools binconfig-disabled lib_package pkgconfig |
| 21 | |
| 22 | EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared" |
| 23 | EXTRA_OECONF += "--without-gssapi" |
| 24 | |
| 25 | do_compile_append() { |
| 26 | oe_runmake -C test |
| 27 | } |